苏飞论坛

 找回密码
 马上注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

分布式系统框架(V1.3) 轻松承载百亿数据,千万流量!讨论专区 - 源码下载 - 官方教程

HttpHelper万能框架(V2.3-含.netcore) HttpHelper官方出品,无敌框架讨论区 - 源码下载 - 在线测试和代码生成

HttpHelper爬虫类(V2.0) 最牛的爬虫类,没有爬不到只有想不到 源码 - 代码生成器 - 讨论区 - 教程- 例子

查看: 742|回复: 7

[HttpHelper] 请求工具类

[复制链接]
发表于 2019-6-10 08:24:12 | 显示全部楼层 |阅读模式
请求工具类昨天试了,不兼容xp系统啊。用xp系统使用还是提示的链接已关闭,怎么解决啊
发表于 2019-6-10 10:04:10 | 显示全部楼层
 楼主| 发表于 2019-6-10 10:46:37 | 显示全部楼层
就是发送https请求到服务器,在getrequest的时候,就已经报错了,显示链接关闭,
The underlying connection was closed an unexpected error occurred on a send
xp系统32位,使用你的Httphelper类
 楼主| 发表于 2019-6-10 10:47:08 | 显示全部楼层
站长苏飞 发表于 2019-6-10 10:04
具体什么功能,详情说一下,

就是发送https请求到服务器,在getrequest的时候,就已经报错了,显示链接关闭,
The underlying connection was closed an unexpected error occurred on a send
xp系统32位,使用你的Httphelper类
 楼主| 发表于 2019-6-10 13:54:40 | 显示全部楼层
发表于 2019-6-10 15:22:33 | 显示全部楼层

ServicePointManager.SecurityProtocol = (SecurityProtocolType)3072; 这个要看协议版本,必须支持net4.0以上应该才行。安装.net4.5
 楼主| 发表于 2019-6-10 15:57:42 | 显示全部楼层
站长苏飞 发表于 2019-6-10 15:22
ServicePointManager.SecurityProtocol = (SecurityProtocolType)3072; 这个要看协议版本,必须支持net4. ...

支持.net4.0 ,但是.net4.0没有Tls12协议啊。xp也不支持.net4.5 ,没办法要求客户换系统呢。只能从这上面下手,但是你这工具类,用了还是那个问题一样的。只要getrequest就抛出链接关闭这个错误,ssl这个也试了。
有解决办法吗?
 楼主| 发表于 2019-6-10 15:58:30 | 显示全部楼层
站长苏飞 发表于 2019-6-10 15:22
ServicePointManager.SecurityProtocol = (SecurityProtocolType)3072; 这个要看协议版本,必须支持net4. ...

可以qq或者微信聊吗。
您需要登录后才可以回帖 登录 | 马上注册

本版积分规则

QQ|手机版|小黑屋|手机版|联系我们|关于我们|广告合作|苏飞论坛 ( 豫ICP备17001017号-1)

GMT+8, 2019-8-26 15:06

© 2017-2018

快速回复 返回顶部 返回列表