苏飞论坛

 找回密码
 马上注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

分布式系统框架(V1.3) 轻松承载百亿数据,千万流量!讨论专区 - 源码下载 - 官方教程

HttpHelper万能框架(V2.3-含.netcore) HttpHelper官方出品,无敌框架讨论区 - 源码下载 - 在线测试和代码生成

HttpHelper爬虫类(V2.0) 最牛的爬虫类,没有爬不到只有想不到 源码 - 代码生成器 - 讨论区 - 教程- 例子

查看: 524|回复: 5

[HttpHelper] 能不能支持http2.0啊

[复制链接]
发表于 2019-6-24 12:38:44 | 显示全部楼层 |阅读模式
有的网站,http1.0跟1.1版本已经无法请求了,非http2.0请求就是返回网关超时啥的
发表于 2019-6-24 14:29:58 | 显示全部楼层
http1.0是看你电脑上是否安装,或者配置文件是否配置的,这个与类应该是无关的。
 楼主| 发表于 2019-7-1 10:25:39 | 显示全部楼层
站长苏飞 发表于 2019-6-24 14:29
http1.0是看你电脑上是否安装,或者配置文件是否配置的,这个与类应该是无关的。

我说的是http2.0
 楼主| 发表于 2019-7-1 10:26:52 | 显示全部楼层
站长苏飞 发表于 2019-6-24 14:29
http1.0是看你电脑上是否安装,或者配置文件是否配置的,这个与类应该是无关的。

用你的类强型把版本改为2.0 并框架是net4.6的情况下,直接提示只支持http1.0或1.1
发表于 2019-7-1 10:32:36 | 显示全部楼层
gaide168 发表于 2019-7-1 10:26
用你的类强型把版本改为2.0 并框架是net4.6的情况下,直接提示只支持http1.0或1.1

这个我就没办法 了,访问类和Http的版本是无关的。这个你不明白可以百度
 楼主| 发表于 2019-7-1 15:01:40 | 显示全部楼层
站长苏飞 发表于 2019-7-1 10:32
这个我就没办法 了,访问类和Http的版本是无关的。这个你不明白可以百度

建议老大真应该百度呢,目前net要实现http2.0访问只有引入 WinHttpHandler ,而且只能在net4.6框架以上下使用, 再者2.0跟1.1还有1.0 完全是两个概念
您需要登录后才可以回帖 登录 | 马上注册

本版积分规则

QQ|手机版|小黑屋|手机版|联系我们|关于我们|广告合作|苏飞论坛 ( 豫ICP备17001017号-1)

GMT+8, 2019-8-26 15:16

© 2017-2018

快速回复 返回顶部 返回列表